
  
<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" /><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>AFN endorses Peltola and Murkowski, citing accomplishments and commitments - Alaska Beacon</title>
	<meta name="description" content="The largest Alaska Native organization endorsed the Democratic and Republican incumbents, both seen as champions of Indigenous causes." />
	<link rel="canonical" href="https://alaskabeacon.com/2022/10/23/afn-endorses-peltola-and-murkowski-citing-accomplishments-and-commitments/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="AFN endorses Peltola and Murkowski, citing accomplishments and commitments - Alaska Beacon" />
	<meta property="og:description" content="The largest Alaska Native organization endorsed the Democratic and Republican incumbents, both seen as champions of Indigenous causes." />
	<meta property="og:url" content="https://alaskabeacon.com/2022/10/23/afn-endorses-peltola-and-murkowski-citing-accomplishments-and-commitments/" />
	<meta property="og:site_name" content="Alaska Beacon" />
	<meta property="article:publisher" content="https://www.facebook.com/AlaskaBeacon" />
	<meta property="article:published_time" content="2022-10-23T23:51:45+00:00" />
	<meta property="article:modified_time" content="2022-10-24T00:27:23+00:00" />
	<meta property="og:image" content="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02391-scaled.jpg" />
	<meta property="og:image:width" content="2560" />
	<meta property="og:image:height" content="1707" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@YJRosen" />
	<meta name="twitter:site" content="@AlaskaBeacon" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Yereth Rosen" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="9 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Alaska Beacon &raquo; Feed" href="https://alaskabeacon.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Alaska Beacon &raquo; Comments Feed" href="https://alaskabeacon.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Alaska Beacon &raquo; AFN endorses Peltola and Murkowski, citing accomplishments and commitments Comments Feed" href="https://alaskabeacon.com/2022/10/23/afn-endorses-peltola-and-murkowski-citing-accomplishments-and-commitments/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/alaskabeacon.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.5"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://alaskabeacon.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.5' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='pluginStyles-css'  href='https://alaskabeacon.com/wp-content/plugins/states-newsroom/assets/css/pluginStyles.css?ver=5.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='https://alaskabeacon.com/wp-content/plugins/states-newsroom/custom-twitter-feeds-pro/css/ctf-styles.css?ver=1.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='search-filter-plugin-styles-css'  href='https://alaskabeacon.com/wp-content/plugins/search-filter-pro/public/assets/css/search-filter.min.css?ver=2.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='child-theme-mincss-css'  href='https://alaskabeacon.com/wp-content/themes/genesis-child/style.css?ver=5.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://alaskabeacon.com/wp-content/themes/genesis-child/css/bootstrap.css?ver=20141119' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://alaskabeacon.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-official-css'  href='https://use.fontawesome.com/releases/v5.15.4/css/all.css' type='text/css' media='all' integrity="sha384-DyZ88mC6Up2uqS4h/KRgHuoeGwBcD4Ng9SiP4dIRy0EXTlnuz47vAwmeGwVChigm" crossorigin="anonymous" />
<link rel='stylesheet' id='font-awesome-official-v4shim-css'  href='https://use.fontawesome.com/releases/v5.15.4/css/v4-shims.css' type='text/css' media='all' integrity="sha384-Vq76wejb3QJM4nDatBa5rUOve+9gkegsjCebvV/9fvXlGWo4HCMR4cJZjjcF6Viv" crossorigin="anonymous" />
<style id='font-awesome-official-v4shim-inline-css' type='text/css'>
@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-brands-400.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.eot"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-solid-900.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.4/webfonts/fa-regular-400.svg#fontawesome") format("svg");
unicode-range: U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD;
}
</style>
<script type='text/javascript' src='https://alaskabeacon.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://alaskabeacon.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='search-filter-plugin-build-js-extra'>
/* <![CDATA[ */
var SF_LDATA = {"ajax_url":"https:\/\/alaskabeacon.com\/wp-admin\/admin-ajax.php","home_url":"https:\/\/alaskabeacon.com\/","extensions":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://alaskabeacon.com/wp-content/plugins/search-filter-pro/public/assets/js/search-filter-build.min.js?ver=2.5.4' id='search-filter-plugin-build-js'></script>
<script type='text/javascript' src='https://alaskabeacon.com/wp-content/plugins/search-filter-pro/public/assets/js/chosen.jquery.min.js?ver=2.5.4' id='search-filter-plugin-chosen-js'></script>
<script type='text/javascript' src='https://alaskabeacon.com/wp-content/themes/genesis-child/js/main.js?ver=5.9.5' id='child-theme-js-js'></script>
<link rel="https://api.w.org/" href="https://alaskabeacon.com/wp-json/" /><link rel="alternate" type="application/json" href="https://alaskabeacon.com/wp-json/wp/v2/posts/3322" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://alaskabeacon.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://alaskabeacon.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.5" />
<link rel='shortlink' href='https://alaskabeacon.com/?p=3322' />
<link rel="alternate" type="application/json+oembed" href="https://alaskabeacon.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falaskabeacon.com%2F2022%2F10%2F23%2Fafn-endorses-peltola-and-murkowski-citing-accomplishments-and-commitments%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://alaskabeacon.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falaskabeacon.com%2F2022%2F10%2F23%2Fafn-endorses-peltola-and-murkowski-citing-accomplishments-and-commitments%2F&#038;format=xml" />
<link rel="pingback" href="https://alaskabeacon.com/xmlrpc.php" />
<link rel="preconnect" href="https://fonts.gstatic.com">
    <link href="https://fonts.googleapis.com/css2?family=Barlow+Condensed:wght@500;600;700&family=Barlow:wght@400;500;600;700;800&family=Montserrat:wght@700;800&family=Newsreader:ital,wght@0,400;0,500;0,600;1,400;1,500;1,600&display=swap" rel="stylesheet">
      
        <script src=
    "https://maxcdn.bootstrapcdn.com/bootstrap/4.3.1/js/bootstrap.min.js">
        </script>        <script async src="https://www.googletagmanager.com/gtag/js?id=UA-227270276-1"></script> 
        <script>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</script>
        <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','dataLayer','GTM-M796B4D');</script>
    <link rel="icon" href="https://alaskabeacon.com/wp-content/uploads/2022/04/cropped-AlaskaSquare_Letters_800px-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://alaskabeacon.com/wp-content/uploads/2022/04/cropped-AlaskaSquare_Letters_800px-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://alaskabeacon.com/wp-content/uploads/2022/04/cropped-AlaskaSquare_Letters_800px-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://alaskabeacon.com/wp-content/uploads/2022/04/cropped-AlaskaSquare_Letters_800px-1-270x270.png" />
</head>
<body class="post-template-default single single-post postid-3322 single-format-standard header-full-width content-sidebar genesis-breadcrumbs-hidden"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M796B4D"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div class="site-container"><header class="site-header"><div class="wrap"><div class="container-fluid topNavFluidContainer">
    <div class="container topNavContainer">
        <nav class="navbar navbar-expand-md navbar-dark ">
            <button class="navbar-toggler collapsed" type="button" data-toggle="collapse" data-target="#navbarSupportedContent" aria-controls="navbarSupportedContent" aria-expanded="false" aria-label="Toggle navigation">
                <span class="navbar-toggler-icon"></span>
                <span class="custom-close-toggler"></span>
            </button>
            <a href="/">
                <img class="mobileNavbar searchHide" src="/wp-content/themes/genesis-child/icons/mobileHeader.svg">
            </a>
            <form id="searchform" role="search" method="get" action="https://alaskabeacon.com/" class="mobileNavbar form-inline my-2 my-lg-0 navSearch">
                <input class="form-control mr-sm-2 headerSearchInput px-2 searchShow" type="text" class="search-field" name="s" placeholder="Search" value="" style="display:none">
                <button value="search" class="headerSearchBtn searchShow" type="submit" style="display:none"><i class="fas fa-search"></i></button>
                <i class="fas fa-search searchHide" id="searchIcon" onclick="openSearch()"></i>
            </form> 
            <div class="collapse navbar-collapse" id="navbarSupportedContent">
                <ul class="navbar-nav mr-auto">
                    <li class="nav-item">
                        <a class="nav-link" href="/">HOME</a>
                    </li>
                    <li class="mobileOnly">
                        <a class="nav-link" href="/news">NEWS</a>
                        <div style="padding-left:22px;">
                            <div class="menu-beats-menu-container"><ul id="menu-beats-menu" class="menu"><li id="menu-item-729" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-729"><a href="https://alaskabeacon.com/category/election-2022/">Election 2022</a></li>
<li id="menu-item-88" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88"><a href="https://alaskabeacon.com/category/econ-environment/">Economy &amp; Environment</a></li>
<li id="menu-item-89" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89"><a href="https://alaskabeacon.com/category/education/">Education</a></li>
<li id="menu-item-91" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91"><a href="https://alaskabeacon.com/category/health/">Health</a></li>
<li id="menu-item-92" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="https://alaskabeacon.com/category/justice/">Justice</a></li>
</ul></div>                        </div>
                    </li>
                    <li class="mobileOnly">
                        <a class="nav-link" href="/commentary">COMMENTARY</a>
                    </li>
                    <li class="nav-item">
                        <a class="nav-link" href="/about">ABOUT</a>
                    </li>
                    <li class="nav-item">
                        <a class="nav-link" href="/subscribe">SUBSCRIBE</a>
                    </li>
                    <li class="nav-item">
                        <a class="nav-link" href="/donate">DONATE</a>
                    </li>
                </ul>
                
<form id="searchform" role="search" method="get" action="https://alaskabeacon.com/" class="form-inline my-2 my-lg-0 navSearch">
	<span>
		<a href="https://twitter.com/AlaskaBeacon" target="_blank"><i class="fab fa-twitter"></i></a>
		<a href="https://www.facebook.com/AlaskaBeacon" target="_blank"><i class="fab fa-facebook-f"></i></a>     
	</span>
	<input class="form-control mr-sm-2 headerSearchInput px-2 searchShow" type="text" class="search-field" name="s" placeholder="Search" value="" style="display:none">
	<button value="search" class="headerSearchBtn searchShow" type="submit" style="display:none"><i class="fas fa-search"></i></button>
	<i class="fas fa-search searchHide" id="searchIcon" onclick="openSearch()"></i>
</form>            </div>
        </nav>
    </div>
</div>
<div class="fullWidthHeaderLogoRow">
    <div class="container">
        <div class="row">
            <div class="col-12 headerLogoCol">
                <a href="https://alaskabeacon.com">
                    <img class="headerLogo" src="/wp-content/themes/genesis-child/icons/headerLogo.png" />
                </a>
            </div>
        </div>
    </div>
</div>
<div class="fullWidthHeaderSecondaryRow">
    <div class="container">
        <div class="row">
            <div class="col-12 headerSecondaryCol">
                <div class="menu-beats-menu-container"><ul id="menu-beats-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-729"><a href="https://alaskabeacon.com/category/election-2022/">Election 2022</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88"><a href="https://alaskabeacon.com/category/econ-environment/">Economy &amp; Environment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-89"><a href="https://alaskabeacon.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91"><a href="https://alaskabeacon.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="https://alaskabeacon.com/category/justice/">Justice</a></li>
</ul></div>            </div>
        </div>
    </div>
</div>
</div></header><div class="site-inner">
    <div id="primary" class="content-area">
        <main id="main" class="site-main" role="main">
            <div class="container">
                <div id="singlePostContainer" class="devPostContainer row">
                    <div class="col-xxl-1 col-xl-1 col-lg-1 col-md-1 col-sm-0 col-0"></div>
                    <div class="col-xxl-10 col-xl-10 col-lg-10 col-md-10 col-sm-12 col-12">
                        <div class="row">
                             
                                <h5 id="dataTime" style="display:none;">15:51</h5>
                                <h5 id="dataType" style="display:none;">News Story</h5>
                                
                                <div class="col-12">
                                    <ul id="dataCats" class="singleCategoryUL" style="list-style: none;">
                                    <li><a class="singleCategory" href="https://alaskabeacon.com/category/election-2022">Election 2022</a></li><li><a class="singleCategory" href="https://alaskabeacon.com/category/gvt-politics">Government &amp; Politics</a></li>                                    </ul>
                                    <h1 id="singleHed" class="singleHed">AFN endorses Peltola and Murkowski, citing accomplishments and commitments</h1>
                                    <h2 class="hedSecond singleHedSecond">Convention attendees embraced the two women, one a Democrat and one a Republican, both seen as champions of Native causes</h2>                                </div>
                            </div>
                            <div class="row singleBylineRow">
                                <div class="col-xxl-8 col-xl-8 col-lg-8 col-md-12 col-sm-12 col-12">
                                    <h6 class="singleBylineContainer"><span  class="singleByline">By: </span><span class="singleBylineAuthor"><a href="https://alaskabeacon.com/author/yereth-rosen/" title="Posts by Yereth Rosen" class="author url fn" rel="author">Yereth Rosen</a> </span><span class="singleByline">- October 23, 2022 </span><span class="singleByline singleBylineSpacer">3:51 pm</span></h6>
                                </div>
                                
                                <div class="col-xxl-4 col-xl-4 col-lg-4 col-md-12 col-sm-12 col-12 singleSocialShares">
                                    <span>
                                        <a target="_blank" href="https://twitter.com/intent/tweet?text=AFN+endorses+Peltola+and+Murkowski%2C+citing+accomplishments+and+commitments&amp;url=https%3A%2F%2Falaskabeacon.com%2F2022%2F10%2F23%2Fafn-endorses-peltola-and-murkowski-citing-accomplishments-and-commitments%2F&amp;via=AlaskaBeacon">
                                            <i class="fab fa-twitter"></i>
                                        </a>
                                        <a target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://alaskabeacon.com/2022/10/23/afn-endorses-peltola-and-murkowski-citing-accomplishments-and-commitments/&amp;title=AFN+endorses+Peltola+and+Murkowski%2C+citing+accomplishments+and+commitments">
                                            <i class="fab fa-linkedin-in"></i>
                                        </a> 
                                        <a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Falaskabeacon.com%2F2022%2F10%2F23%2Fafn-endorses-peltola-and-murkowski-citing-accomplishments-and-commitments%2F">
                                            <i class="fab fa-facebook-f"></i>   
                                        </a>  
                                        <a target="_blank" href="/cdn-cgi/l/email-protection#a59ad6d0c7cfc0c6d198e4e3eb8ec0cbc1cad7d6c0d68ef5c0c9d1cac9c48ec4cbc18ee8d0d7cecad2d6cecc8097e68ec6ccd1cccbc28ec4c6c6cac8d5c9ccd6cdc8c0cbd1d68ec4cbc18ec6cac8c8ccd1c8c0cbd1d683c4c8d59ec7cac1dc98cdd1d1d5d69f8a8ac4c9c4d6cec4c7c0c4c6cacb8bc6cac88a979597978a94958a97968ac4c3cb88c0cbc1cad7d6c0d688d5c0c9d1cac9c488c4cbc188c8d0d7cecad2d6cecc88c6ccd1cccbc288c4c6c6cac8d5c9ccd6cdc8c0cbd1d688c4cbc188c6cac8c8ccd1c8c0cbd1d68a">
                                            <i class="fas fa-envelope"></i>
                                        </a> 
                                        <a onclick="copyLinkShare('https://alaskabeacon.com/2022/10/23/afn-endorses-peltola-and-murkowski-citing-accomplishments-and-commitments/')">
                                            <i class="fas fa-link"></i>   
                                            
                                        </a>  
                                        <a onclick="printArticle()" >
                                            <i class="fas fa-print"></i>  
                                        </a>                               
                                    </span>
                                </div>
                            </div>
                            <div class="row singleFeatImageRow">
                                <div class="col-12 px-0">
                                                                            <figure class="singleFeaturedImage"> <a href="https://alaskabeacon.com/2022/10/23/afn-endorses-peltola-and-murkowski-citing-accomplishments-and-commitments/"><img width="1024" height="683" src="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02391-1024x683.jpg" class="attachment-large size-large wp-post-image" alt="Lisa Murkowski poses for photos on Saturday at the close of the Alaska Federation of Natives convention with Joe Nelson and Ana Hoffman, co-chairs of the organization, and AFN Executive Vice President Nicole Borromeo. AFN, the largest Native organization in Alaska, endorsed both Murkowski and U.S. Rep. Mary Peltola, the first Alaska Native to serve in Congress. Two Murkowski campaign staffers, Grace Jang and Shea Siegert, are using smartphones to take the photos. (Photo by Yereth Rosen/Alaska Beacon)" srcset="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02391-1024x683.jpg 1024w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02391-300x200.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02391-768x512.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02391-1536x1024.jpg 1536w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02391-2048x1365.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /></a> </figure>
                                      
                                    <p class="singleImageCaption"><i class="fas fa-camera"></i> Lisa Murkowski poses for photos on Saturday at the close of the Alaska Federation of Natives convention with Joe Nelson and Ana Hoffman, co-chairs of the organization, and AFN Executive Vice President Nicole Borromeo. The AFN, Alaska's largest Native organization, endorsed Murkowski, who is facing a Donald Trump-endosed challenger, and U.S. Rep. Mary Peltola, who became the first Alaska Native to serve in Congress after she won a special election in August. Peltola is defending her seat in the general election. AFN delegates described both women as powerful advocates and allies. (Photo by Yereth Rosen/Alaska Beacon)</p> 
                                </div>
                            </div>
                            <div class="row">
                                <div class="col-xxl-1 col-xl-1 col-lg-1 col-md-0 col-sm-0 col-0"></div>
                                <div id="dataContent" class="col-xxl-10 col-xl-10 col-lg-10 col-md-12 col-sm-12 col-12 contentHolder">
                                    <p><span style="font-weight: 400;">Alaska’s largest Indigenous organization on Saturday endorsed the reelection campaigns of both U.S. Rep. Mary Peltola, a Democrat, and Sen. Lisa Murkowski, a Republican, backing two lawmakers seen by the members as champions of Native issues.</span></p>
<p><span style="font-weight: 400;">	<div class="newsroomSidebarContainer">
	<div class="newsroomSidebar "></span><a target="_blank" href="https://alaskabeacon.com/2022/09/30/alaska-candidate-comparison-tool-allows-voters-to-explore-positions-in-statewide-races/"><span style="font-weight: 400;">Alaska candidate comparison tool allows voters to explore positions in statewide races</span></a><span style="font-weight: 400;"></div>
	</div>
	“It’s pretty unanimous that everybody is for the two candidates,” said Jodi Mitchell, who chaired the resolutions committee at this year’s Alaska Federation of Natives convention.</span></p>
<p><span style="font-weight: 400;">Delegates at the convention endorsed the two women “because of their outstanding contributions,” said Mitchell, an executive with the Juneau-based, Native-owned Sealaska Corp.</span></p>
<p><span style="font-weight: 400;">Candidate endorsements from AFN are made only occasionally. There was no endorsement made for this year’s gubernatorial race, for example, and no endorsements were made at all in 2020.</span></p>
<p><span style="font-weight: 400;">The Peltola endorsement was likely anticipated, even by her rivals, after successive convention days in which she was honored and celebrated. Peltola, who is Yup’ik and from the Yukon-Kuskokwim Delta region, became the first Alaska Native in Congress after she won a special election in August to fill the remaining months of the late Rep. Don Young’s term.</span></p>
<p><span style="font-weight: 400;">    <div class="halfwidth">
        </span></p>
<figure id="attachment_3303" class="wp-caption alignnone" style="max-width:100%;width:2560px;"><img loading="lazy" class="wp-image-3303 size-full" src="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02179-scaled.jpg" alt="Fans of Mary Peltola, listening to the the U.S. House candidate forum at the Alaska Federation of Natives conference on Saturday, hold up signs with images of her face. From right, they are Francine Morena, Jackie Oliver and Leyla Kelter, all of Anchorage. (Photo by Yereth Rosen/Alaska Beacon)" width="2560" height="1707" srcset="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02179-scaled.jpg 2560w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02179-300x200.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02179-1024x683.jpg 1024w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02179-768x512.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02179-1536x1024.jpg 1536w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02179-2048x1365.jpg 2048w" sizes="(max-width: 2560px) 100vw, 2560px" /><figcaption class="wp-caption-text"><i class="fas fa-camera"></i>  Fans of Mary Peltola, listening to the U.S. House candidate forum at the Alaska Federation of Natives convention on Saturday, hold up signs with images of her face. From right, they are Francine Morena, Jackie Oliver and Leyla Kelter, all of Anchorage. (Photo by Yereth Rosen/Alaska Beacon)</p></figure>
<p><span style="font-weight: 400;">    </div>

	A rock-star-like presence at the convention, she was also feted Saturday night by some real rock stars, the musicians of Portugal. The Man and Pamyua, who held a <a target="_blank" href="https://twitter.com/MaryPeltola/status/1583989727467687937">concert</a> in her honor.</span></p>
<p><span style="font-weight: 400;">Former Gov. Sarah Palin, a Republican who lost to Peltola in the August special election and who is running against her in the November general election, said the new House member’s popularity makes this the toughest campaign in her career.</span></p>
<p><span style="font-weight: 400;">“We are in Mary’s house, and I know that. And I love her dearly. I’m as proud of her as all of you are,” Palin said at a Saturday candidate forum. “Doggone it, I never have anything left to gripe about her. I just wish she’d convert on over to the other party.”</span></p>
<p><span style="font-weight: 400;">As for Murkowski – a longtime friend and ally of Peltola who told the Anchorage Daily News on Friday that the new House member is <a target="_blank" href="https://www.adn.com/politics/2022/10/21/at-afn-murkowski-says-shell-vote-for-longtime-friend-and-democrat-mary-peltola-for-us-house/">her first choice</a> in the November House election, Saturday’s endorsement was somewhat reminiscent of an AFN endorsement made in 2010. In that year, the senator mounted what turned out to be a successful re-election write-in campaign after being defeated in the Republican primary by Joe Miller, a Tea Party-backed candidate who challenged Murkowski from the right.</span></p>
<p><span style="font-weight: 400;">This year, Murkowski is being challenged by another challenger well to her right, Kelly Tshibaka, a former member of Gov. Mike Dunleavy’s cabinet. Tshibaka is endorsed by former President Donald Trump; Murkowski earned Trump’s ire by opposing him in some instances and by voting to convict him in his second impeachment trial. </span></p>
<p><span style="font-weight: 400;">    <div class="halfwidth">
        </span></p>
<figure id="attachment_3301" class="wp-caption alignnone" style="max-width:100%;width:1024px;"><img loading="lazy" class="wp-image-3301 size-large" src="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC01806-1024x683.jpg" alt="Carver Earl Atchak of Chevak displays his Mary Peltola doll on Friday at the Alaska Federation of Natives convention arts and crafts fair. The face is carved of walrus ivory, said Atchak, a celebrated Yup'ik carver. The doll was not for sale, he said. (Photo by Yereth Rosen/Alaska Beacon)" width="1024" height="683" srcset="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC01806-1024x683.jpg 1024w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC01806-300x200.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC01806-768x512.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC01806-1536x1024.jpg 1536w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC01806-2048x1365.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text"><i class="fas fa-camera"></i>  Carver Earl Atchak of Chevak displays his Mary Peltola doll on Friday at the Alaska Federation of Natives convention arts and crafts fair. The face is carved of walrus ivory, said Atchak, a celebrated Yup&#8217;ik carver. The doll was not for sale, he said. (Photo by Yereth Rosen/Alaska Beacon)</p></figure>
<p><span style="font-weight: 400;">    </div>

	Unlike 2010, this year’s election is being conducted in a new Alaska system with open primaries and ranked choice voting in the general election.</span></p>
<p><span style="font-weight: 400;">    <h4 class="editorialSubhed">Fish and rural law enforcement get attention in House candidate forum</h4>

	In the back-to-back candidate forums held at the AFN convention Saturday morning, Peltola and Murkowski outlined their plans for continued work if they are sent back to Congress. </span></p>
<p><span style="font-weight: 400;">Peltola said threats to food security – especially the collapse of salmon runs on which Indigenous Alaskans depend – was what motivated her to run for Congress in the first place. Reauthorizing and modernizing the Magnuson-Stevens Fishery Conservation and Management Act, the law governing seafood harvests in federal waters, is one of her top priorities, she said. She started working on that project even before she was elected in August in her role as executive director of the Kuskokwim River Inter-Tribal Fish Commission.</span></p>
<p><span style="font-weight: 400;">“We do need to see that that bill is reauthorized, with the recognition that we are in a different paradigm. We have a different ocean. We have different productivity levels,” Peltola said at the Saturday candidate forum.</span></p>
<p><span style="font-weight: 400;">Infrastructure deficiencies and housing shortages, problems that are especially dire in rural Alaska, came up in the debate. So did law enforcement, another service that is scarce in many rural Indigenous communities. Peltola argued – and her rivals generally agreed – that federal funding for law enforcement in the mostly Indigenous areas of rural Alaska should be more dependable, and not fluctuate widely year-to-year. She urged better support for substance-abuse treatment, tribal courts and other programs, and she described desperate conditions in villages that lack law enforcement entirely.</span></p>
<p><span style="font-weight: 400;">“We have to have law enforcement, and I don’t understand the debate that is going across the country to defund public safety,” Peltola said. “That has never been a message in Alaska. We have been begging and pleading and finding all kinds of unique and creative ways to fund public safety.”</span></p>
<p><span style="font-weight: 400;">    <div class="halfwidth">
        </span></p>
<figure id="attachment_3320" class="wp-caption alignnone" style="max-width:100%;width:1024px;"><img loading="lazy" class="wp-image-3320 size-large" src="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02113-1024x683.jpg" alt="Republican Nick Begich waves to the crowd at Saturday's U.S. House candidate forum held at the Alaska Federation of Natives annual convention. Other candidates are Libertarian Nick Bye, on the left, and U.S. Rep. Mary Peltola, a Democrat, and former Gov. Sarah Palin, a Republican, on the right. (Photo by Yereth Rosen/Alaska Beacon)" width="1024" height="683" srcset="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02113-1024x683.jpg 1024w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02113-300x200.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02113-768x512.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02113-1536x1024.jpg 1536w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02113-2048x1365.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text"><i class="fas fa-camera"></i>  Republican Nick Begich waves to the crowd at Saturday&#8217;s U.S. House candidate forum held at the Alaska Federation of Natives annual convention. Other candidates are Libertarian Nick Bye, on the left, and U.S. Rep. Mary Peltola, a Democrat, and former Gov. Sarah Palin, a Republican, on the right. (Photo by Yereth Rosen/Alaska Beacon)</p></figure>
<p><span style="font-weight: 400;">    </div>

	Her opponents hit familiar themes that have become familiar during multiple candidate events throughout the campaign season.</span></p>
<p><span style="font-weight: 400;">Palin expressed her opposition to President Joe Biden’s natural-resource policies. “We have got to stop President Biden’s war on energy,” she said. Her anti-Biden comments went further. One of her priorities, if elected, she said would be to combat the “crony capitalism” that she claimed had enveloped the president’s family. “The Biden family, the links to Communist China: They need to be investigated,” she said.</span></p>
<p><span style="font-weight: 400;">Begich described himself as a “full-throated advocate” for resource development who will make “the business case for Alaska.”</span></p>
<p><span style="font-weight: 400;">“I’m running because I believe in our state’s motto, ‘North to the Future.’ And I believe that Alaska’s future is a core part of America’s future,” he said. “We’ve been tremendously blessed with mineral resources, energy resources and a unique geographic position in this world to provide national security to the rest of America.”</span></p>
<p><span style="font-weight: 400;">Libertarian Chris Bye, a Fairbanks fishing guide, described himself as “just a normal Alaskan” and argued for moving decision-making from the federal level to the local level whenever possible.</span></p>
<p><span style="font-weight: 400;">“You’ll see most of my answers to the questions today revolve around tribal sovereignty, because I believe local solutions are better than ones built upon D.C. politicians,” Bye said.</span></p>
    <a href="/subscribe" style="text-decoration:none;">
    <div class="subscribeShortcodeContainer">
        <div class="subscribeTextContainer">
			<i class="fas fa-envelope"></i>
            <p>GET THE MORNING HEADLINES DELIVERED TO YOUR INBOX</p>
        </div>
        <div class="subscribeButtonContainer">
            <button>SUBSCRIBE</button>
        </div>
    </div>
    </a>
	
<p><span style="font-weight: 400;">    <h4 class="editorialSubhed">Sharp exchanges &#8212; and some points of agreement &#8212; in Senate forum</h4>

	In the Senate forum, which also featured Democrat Pat Chesbro as well as Tshibaka, Murkowski emphasized her experience and what she said were the important accomplishments she has already achieved for Alaska.</span></p>
<p><span style="font-weight: 400;">    <div class="halfwidth">
        </span></p>
<figure id="attachment_3309" class="wp-caption alignnone" style="max-width:100%;width:1024px;"><img loading="lazy" class="wp-image-3309 size-large" src="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02274-1024x683.jpg" alt="Republican candidate Kelly Tshibaka speaks at Saturday's candidate forum held at the Alaska Federation of Natives convention. Tshibaka, who is endorsed by former President Donald Trump, spent much of the forum lobbing attacks on Sen. Lisa Murkowski, but she did not mention the inumbent's name. (Photo by Yereth Rosen./Alaska Beacon)" width="1024" height="683" srcset="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02274-1024x683.jpg 1024w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02274-300x200.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02274-768x512.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02274-1536x1024.jpg 1536w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02274-2048x1365.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text"><i class="fas fa-camera"></i>  Republican candidate Kelly Tshibaka speaks at Saturday&#8217;s candidate forum held at the Alaska Federation of Natives convention. Tshibaka, who is endorsed by former President Donald Trump, spent much of the forum lobbing attacks on Sen. Lisa Murkowski, but she did not mention the inumbent&#8217;s name. (Photo by Yereth Rosen/Alaska Beacon)</p></figure>
<p><span style="font-weight: 400;">    </div>

	“It helps to have somebody who’s boots on the ground, knows what’s going on and can move from Day One,” she said in response to a question about first priorities in the new session of Congress.</span></p>
<p><span style="font-weight: 400;">Tshibaka made critical statements without mentioning the senator’s name.</span></p>
<p><span style="font-weight: 400;">That included a swipe at Murkowski’s approval of some Biden-nominated federal officials. “I’ll prioritize responsible resource development after our Alaskan voice was used to confirm radical nominees that shut down our industries, killed our jobs and took away our voice in developing resources,” Tshibaka said.</span></p>
<p><span style="font-weight: 400;">And it included infrastructure plans for Alaska, a source of pride for Murkowski, who coauthored the 2021 Infrastructure Investment and Jobs Act. Tskibaka said funding promised to Alaska will not come “because the Biden bureaucracy has buried the money under a pile of regulations.”</span></p>
<p><span style="font-weight: 400;">Murkowski shot back, saying already $420 million had come to Alaska for rural broadband expansion alone.</span></p>
<p><span style="font-weight: 400;">In contrast to the back-and-forth with Tshibaka, Murkowski found common ground with Chesbro. Among the subjects where they found some agreement were related to climate change.</span></p>
<p><span style="font-weight: 400;">Chesbro made a plea for action, putting environmental problems into a holistic health context. “This affects the fish. This affects the storms that we see. This affects the people’s mental health as well. We need to work together to find the many ways that we need to address helping the climate become more healthy,” she said.</span></p>
<p><span style="font-weight: 400;">    <div class="halfwidth">
        </span></p>
<figure id="attachment_3313" class="wp-caption alignnone" style="max-width:100%;width:1024px;"><img loading="lazy" class="wp-image-3313 size-large" src="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02291-1024x683.jpg" alt="Democrat Pat Chesbro speaks at a candidate forum held Saturday at the Alaska Federation of Natives annual convention in Anchorage. Chesbro called for more action to address climate change, and she found points of agreement with the incumbent, Republican Sen. Lisa Murkowski (Photo by Yereth Rosen/Alaska Beacon)" width="1024" height="683" srcset="https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02291-1024x683.jpg 1024w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02291-300x200.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02291-768x512.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02291-1536x1024.jpg 1536w, https://alaskabeacon.com/wp-content/uploads/2022/10/DSC02291-2048x1365.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption class="wp-caption-text"><i class="fas fa-camera"></i>  Democrat Pat Chesbro speaks at a candidate forum held Saturday at the Alaska Federation of Natives annual convention in Anchorage. Chesbro called for more action to address climate change, and she found points of agreement with the incumbent, Republican Sen. Lisa Murkowski. (Photo by Yereth Rosen/Alaska Beacon)</p></figure>
<p><span style="font-weight: 400;">    </div>

	Chesbro cited as a specific problem the ongoing automation of weather stations in Alaska, and Murkowski agreed with her. “That is an issue, when we think to the automation as opposed to the eyes on the ground,” Murkowski said.</span></p>
<p><span style="font-weight: 400;">The changes in the region are profound, a point made when she recently visited the Bering Sea village of Unalakleet, the senator said. Elders there report that they can no longer predict the weather in ways they used to do, she said. “The traditional signals, whether it&#8217;s grass or otherwise, or when it’s safe to go out, are no longer reliable. That’s scary,” she said.</span></p>
<p><span style="font-weight: 400;">The three candidates spent much of the forum talking about Arctic issues.</span></p>
<p><span style="font-weight: 400;">Tshibaka did not mention climate change, but focused instead on national security. “We know that the truth is that the Arctic is opening up. And with the tensions increasing between Russia. . .with nations like Russia and China, we need to pay attention to this.” She said her experience working in the federal government with national security agencies made her especially qualified to advocate for strengthening “our readiness and preparedness in the Arctic.”</span></p>
<p><span style="font-weight: 400;">Murkowski also listed several Arctic security concerns, and she cited her policy accomplishments in that area. She listed her successes in getting funding for three new U.S. Coast Guard icebreakers, deployments of cutters and aircraft in the Bering Sea and northwestern Alaska, the <a target="_blank" href="https://www.pacaf.af.mil/News/Article-Display/Article/3137408/ted-stevens-center-for-arctic-security-studies-opens-on-jber/">Ted Stevens Center for Arctic Security Studies &#8212; </a>which opened this summer at Joint Base Elmendorf-Richardson &#8212; and expansion of the <a target="_blank" href="https://www.poa.usace.army.mil/Library/Reports-and-Studies/Port-of-Nome-Modification-Project/">Port of Nome</a>, among other items. She said she will continue to work to ensure that the Alaska National Guard gets additional funding.</span></p>
<p><span style="font-weight: 400;"> “I’m known as the Arctic senator. I’m quite proud of that,” she said. “We’ve got much work to do.”</span></p>
    <a href="/donate" style="text-decoration:none;">
    <div class="donateContainer">
        <div class="donateTextContainer">
            <p>SUPPORT NEWS YOU TRUST.</p>
        </div>
        <div class="donateButtonContainer">
            <button>DONATE</button>
        </div>
    </div>
    </a>
	
                                </div>
                                <div class="col-xxl-1 col-xl-1 col-lg-1 col-md-0 col-sm-0 col-0"></div>
                            </div>
                            <div class="row">
                                <div class="col-xxl-1 col-xl-1 col-lg-1 col-md-0 col-sm-0 col-0"></div>
                                <div class="col-xxl-10 col-xl-10 col-lg-10 col-md-12 col-sm-12 col-12 contentHolder">
                                    <div class="row singleRepublisherRow">
                                        <div class="col-xxl-5 col-xl-5 col-lg-5 col-md-5 col-sm-12 col-12">
                                            <aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar"><section id="republication_tracker_tool-2" class="widget republication_tracker_tool"><div class="widget-wrap"><div id="republication-tracker-tool-modal-content" style="display:none;"><div class="republication-tracker-tool-close">X</div><div class="cc-policy"><style>#republication-tracker-tool-modal-content .articleContainer textarea {height:80px;}.repubAccordion{font-family: "Barlow Condensed", sans-serif; font-weight: 600; font-size: 21px; letter-spacing: .5px; margin-right: 15px; text-transform: uppercase; color: var(--link_blue) !important; background-image: linear-gradient(180deg ,transparent 65%,#E5E9ED 0); background-size: 0 100%; background-repeat: no-repeat; text-decoration: none; transition: background-size .4s ease;margin-bottom:22px;}.repubAccordion:hover{color: var(--brand_one) !important; background-size: 100% 100%;}.republisherButton{margin-top:22px;}</style></div><div class="articleContainer"><div class="article-info"><h1>AFN endorses Peltola and Murkowski, citing accomplishments and commitments</h1>
<p class="byline">by Yereth Rosen, <a href="https://alaskabeacon.com">Alaska Beacon</a> <br />October 23, 2022</p>
</div><textarea><h1>AFN endorses Peltola and Murkowski, citing accomplishments and commitments</h1>
<p>by Yereth Rosen, <a href="https://alaskabeacon.com">Alaska Beacon</a> <br />October 23, 2022</p>
 <p>Alaska’s largest Indigenous organization on Saturday endorsed the reelection campaigns of both U.S. Rep. Mary Peltola, a Democrat, and Sen. Lisa Murkowski, a Republican, backing two lawmakers seen by the members as champions of Native issues.</p>
<p>	<div class="newsroomSidebarContainer">
	<div class="newsroomSidebar "><a href="https://alaskabeacon.com/2022/09/30/alaska-candidate-comparison-tool-allows-voters-to-explore-positions-in-statewide-races/">Alaska candidate comparison tool allows voters to explore positions in statewide races</a></div>
	</div>
	“It’s pretty unanimous that everybody is for the two candidates,” said Jodi Mitchell, who chaired the resolutions committee at this year’s Alaska Federation of Natives convention.</p>
<p>Delegates at the convention endorsed the two women “because of their outstanding contributions,” said Mitchell, an executive with the Juneau-based, Native-owned Sealaska Corp.</p>
<p>Candidate endorsements from AFN are made only occasionally. There was no endorsement made for this year’s gubernatorial race, for example, and no endorsements were made at all in 2020.</p>
<p>The Peltola endorsement was likely anticipated, even by her rivals, after successive convention days in which she was honored and celebrated. Peltola, who is Yup’ik and from the Yukon-Kuskokwim Delta region, became the first Alaska Native in Congress after she won a special election in August to fill the remaining months of the late Rep. Don Young’s term.</p>
<p>    <div class="halfwidth">
        </p>
<figure><i></i>  Fans of Mary Peltola, listening to the U.S. House candidate forum at the Alaska Federation of Natives convention on Saturday, hold up signs with images of her face. From right, they are Francine Morena, Jackie Oliver and Leyla Kelter, all of Anchorage. (Photo by Yereth Rosen/Alaska Beacon)</p></figure>
<p>    </div>

	A rock-star-like presence at the convention, she was also feted Saturday night by some real rock stars, the musicians of Portugal. The Man and Pamyua, who held a <a href="https://twitter.com/MaryPeltola/status/1583989727467687937">concert</a> in her honor.</p>
<p>Former Gov. Sarah Palin, a Republican who lost to Peltola in the August special election and who is running against her in the November general election, said the new House member’s popularity makes this the toughest campaign in her career.</p>
<p>“We are in Mary’s house, and I know that. And I love her dearly. I’m as proud of her as all of you are,” Palin said at a Saturday candidate forum. “Doggone it, I never have anything left to gripe about her. I just wish she’d convert on over to the other party.”</p>
<p>As for Murkowski – a longtime friend and ally of Peltola who told the Anchorage Daily News on Friday that the new House member is <a href="https://www.adn.com/politics/2022/10/21/at-afn-murkowski-says-shell-vote-for-longtime-friend-and-democrat-mary-peltola-for-us-house/">her first choice</a> in the November House election, Saturday’s endorsement was somewhat reminiscent of an AFN endorsement made in 2010. In that year, the senator mounted what turned out to be a successful re-election write-in campaign after being defeated in the Republican primary by Joe Miller, a Tea Party-backed candidate who challenged Murkowski from the right.</p>
<p>This year, Murkowski is being challenged by another challenger well to her right, Kelly Tshibaka, a former member of Gov. Mike Dunleavy’s cabinet. Tshibaka is endorsed by former President Donald Trump; Murkowski earned Trump’s ire by opposing him in some instances and by voting to convict him in his second impeachment trial. </p>
<p>    <div class="halfwidth">
        </p>
<figure><i></i>  Carver Earl Atchak of Chevak displays his Mary Peltola doll on Friday at the Alaska Federation of Natives convention arts and crafts fair. The face is carved of walrus ivory, said Atchak, a celebrated Yup&#8217;ik carver. The doll was not for sale, he said. (Photo by Yereth Rosen/Alaska Beacon)</p></figure>
<p>    </div>

	Unlike 2010, this year’s election is being conducted in a new Alaska system with open primaries and ranked choice voting in the general election.</p>
<p>    <h4>Fish and rural law enforcement get attention in House candidate forum</h4>

	In the back-to-back candidate forums held at the AFN convention Saturday morning, Peltola and Murkowski outlined their plans for continued work if they are sent back to Congress. </p>
<p>Peltola said threats to food security – especially the collapse of salmon runs on which Indigenous Alaskans depend – was what motivated her to run for Congress in the first place. Reauthorizing and modernizing the Magnuson-Stevens Fishery Conservation and Management Act, the law governing seafood harvests in federal waters, is one of her top priorities, she said. She started working on that project even before she was elected in August in her role as executive director of the Kuskokwim River Inter-Tribal Fish Commission.</p>
<p>“We do need to see that that bill is reauthorized, with the recognition that we are in a different paradigm. We have a different ocean. We have different productivity levels,” Peltola said at the Saturday candidate forum.</p>
<p>Infrastructure deficiencies and housing shortages, problems that are especially dire in rural Alaska, came up in the debate. So did law enforcement, another service that is scarce in many rural Indigenous communities. Peltola argued – and her rivals generally agreed – that federal funding for law enforcement in the mostly Indigenous areas of rural Alaska should be more dependable, and not fluctuate widely year-to-year. She urged better support for substance-abuse treatment, tribal courts and other programs, and she described desperate conditions in villages that lack law enforcement entirely.</p>
<p>“We have to have law enforcement, and I don’t understand the debate that is going across the country to defund public safety,” Peltola said. “That has never been a message in Alaska. We have been begging and pleading and finding all kinds of unique and creative ways to fund public safety.”</p>
<p>    <div class="halfwidth">
        </p>
<figure><i></i>  Republican Nick Begich waves to the crowd at Saturday&#8217;s U.S. House candidate forum held at the Alaska Federation of Natives annual convention. Other candidates are Libertarian Nick Bye, on the left, and U.S. Rep. Mary Peltola, a Democrat, and former Gov. Sarah Palin, a Republican, on the right. (Photo by Yereth Rosen/Alaska Beacon)</p></figure>
<p>    </div>

	Her opponents hit familiar themes that have become familiar during multiple candidate events throughout the campaign season.</p>
<p>Palin expressed her opposition to President Joe Biden’s natural-resource policies. “We have got to stop President Biden’s war on energy,” she said. Her anti-Biden comments went further. One of her priorities, if elected, she said would be to combat the “crony capitalism” that she claimed had enveloped the president’s family. “The Biden family, the links to Communist China: They need to be investigated,” she said.</p>
<p>Begich described himself as a “full-throated advocate” for resource development who will make “the business case for Alaska.”</p>
<p>“I’m running because I believe in our state’s motto, ‘North to the Future.’ And I believe that Alaska’s future is a core part of America’s future,” he said. “We’ve been tremendously blessed with mineral resources, energy resources and a unique geographic position in this world to provide national security to the rest of America.”</p>
<p>Libertarian Chris Bye, a Fairbanks fishing guide, described himself as “just a normal Alaskan” and argued for moving decision-making from the federal level to the local level whenever possible.</p>
<p>“You’ll see most of my answers to the questions today revolve around tribal sovereignty, because I believe local solutions are better than ones built upon D.C. politicians,” Bye said.</p>
    <a href="/subscribe">
    <div class="subscribeShortcodeContainer">
        <div class="subscribeTextContainer">
			<i></i>
            <p>GET THE MORNING HEADLINES DELIVERED TO YOUR INBOX</p>
        </div>
        <div class="subscribeButtonContainer">
            SUBSCRIBE
        </div>
    </div>
    </a>
	
<p>    <h4>Sharp exchanges &#8212; and some points of agreement &#8212; in Senate forum</h4>

	In the Senate forum, which also featured Democrat Pat Chesbro as well as Tshibaka, Murkowski emphasized her experience and what she said were the important accomplishments she has already achieved for Alaska.</p>
<p>    <div class="halfwidth">
        </p>
<figure><i></i>  Republican candidate Kelly Tshibaka speaks at Saturday&#8217;s candidate forum held at the Alaska Federation of Natives convention. Tshibaka, who is endorsed by former President Donald Trump, spent much of the forum lobbing attacks on Sen. Lisa Murkowski, but she did not mention the inumbent&#8217;s name. (Photo by Yereth Rosen/Alaska Beacon)</p></figure>
<p>    </div>

	“It helps to have somebody who’s boots on the ground, knows what’s going on and can move from Day One,” she said in response to a question about first priorities in the new session of Congress.</p>
<p>Tshibaka made critical statements without mentioning the senator’s name.</p>
<p>That included a swipe at Murkowski’s approval of some Biden-nominated federal officials. “I’ll prioritize responsible resource development after our Alaskan voice was used to confirm radical nominees that shut down our industries, killed our jobs and took away our voice in developing resources,” Tshibaka said.</p>
<p>And it included infrastructure plans for Alaska, a source of pride for Murkowski, who coauthored the 2021 Infrastructure Investment and Jobs Act. Tskibaka said funding promised to Alaska will not come “because the Biden bureaucracy has buried the money under a pile of regulations.”</p>
<p>Murkowski shot back, saying already $420 million had come to Alaska for rural broadband expansion alone.</p>
<p>In contrast to the back-and-forth with Tshibaka, Murkowski found common ground with Chesbro. Among the subjects where they found some agreement were related to climate change.</p>
<p>Chesbro made a plea for action, putting environmental problems into a holistic health context. “This affects the fish. This affects the storms that we see. This affects the people’s mental health as well. We need to work together to find the many ways that we need to address helping the climate become more healthy,” she said.</p>
<p>    <div class="halfwidth">
        </p>
<figure><i></i>  Democrat Pat Chesbro speaks at a candidate forum held Saturday at the Alaska Federation of Natives annual convention in Anchorage. Chesbro called for more action to address climate change, and she found points of agreement with the incumbent, Republican Sen. Lisa Murkowski. (Photo by Yereth Rosen/Alaska Beacon)</p></figure>
<p>    </div>

	Chesbro cited as a specific problem the ongoing automation of weather stations in Alaska, and Murkowski agreed with her. “That is an issue, when we think to the automation as opposed to the eyes on the ground,” Murkowski said.</p>
<p>The changes in the region are profound, a point made when she recently visited the Bering Sea village of Unalakleet, the senator said. Elders there report that they can no longer predict the weather in ways they used to do, she said. “The traditional signals, whether it&#8217;s grass or otherwise, or when it’s safe to go out, are no longer reliable. That’s scary,” she said.</p>
<p>The three candidates spent much of the forum talking about Arctic issues.</p>
<p>Tshibaka did not mention climate change, but focused instead on national security. “We know that the truth is that the Arctic is opening up. And with the tensions increasing between Russia. . .with nations like Russia and China, we need to pay attention to this.” She said her experience working in the federal government with national security agencies made her especially qualified to advocate for strengthening “our readiness and preparedness in the Arctic.”</p>
<p>Murkowski also listed several Arctic security concerns, and she cited her policy accomplishments in that area. She listed her successes in getting funding for three new U.S. Coast Guard icebreakers, deployments of cutters and aircraft in the Bering Sea and northwestern Alaska, the <a href="https://www.pacaf.af.mil/News/Article-Display/Article/3137408/ted-stevens-center-for-arctic-security-studies-opens-on-jber/">Ted Stevens Center for Arctic Security Studies &#8212; </a>which opened this summer at Joint Base Elmendorf-Richardson &#8212; and expansion of the <a href="https://www.poa.usace.army.mil/Library/Reports-and-Studies/Port-of-Nome-Modification-Project/">Port of Nome</a>, among other items. She said she will continue to work to ensure that the Alaska National Guard gets additional funding.</p>
<p> “I’m known as the Arctic senator. I’m quite proud of that,” she said. “We’ve got much work to do.”</p>
    <a href="/donate">
    <div class="donateContainer">
        <div class="donateTextContainer">
            <p>SUPPORT NEWS YOU TRUST.</p>
        </div>
        <div class="donateButtonContainer">
            DONATE
        </div>
    </div>
    </a>
	
<style> figure, .tipContainer, .socContainer, .subscribeShortcodeContainer, .donateContainer {display:none !important;} .youtubeContainer { position: relative; padding-bottom: 56.25%; padding-top: 30px; height: 0; overflow: hidden; margin-bottom:12px; } .youtubeContainer iframe, .video-container object, .video-container embed { position: absolute; top: 0; left: 0; width: 100% !important; height: 100%; margin: 12px 0px !important; } .newsroomSidebar {width:35%;max-width:35%;padding:10px;border-top:solid 2px black;background-color:#d3d3d3;float:right;margin-left:50px;} .snrsInfoboxSubContainer {padding:10px;border-top:solid 2px black;background-color:#d3d3d3;} .halfwidth {float:right;width:50%;max-width:50%;} .indent2Container {margin-left: 1em;margin-bottom:1em; border-left: solid 1px black;padding-left: 2em;} @media only screen and (max-width: 600px) {.newsroomSidebar {max-width:95%;width:95%;margin-left:4%} .halfwidth {float:none;width:100%;max-width:100%;} }</style>

 <p><a href="https://alaskabeacon.com">Alaska Beacon</a> is part of States Newsroom, a network of news bureaus supported by grants and a coalition of donors as a 501c(3) public charity. Alaska Beacon maintains editorial independence. Contact Editor Andrew Kitchenman for questions: <a href="mailto:info@alaskabeacon.com">info@alaskabeacon.com</a>. Follow Alaska Beacon on <a href="https://facebook.com/AlaskaBeacon">Facebook</a> and <a href="https://twitter.com/AlaskaBeacon">Twitter</a>.</p></textarea>	<div class="row">
		<div class="col-12 col-md-6 d-flex justify-content-center flex-column align-items-center align-content-center align-content-md-start align-items-md-start">
		<a href="/republishing-guidelines" target="_blank" class="repubAccordion" style="margin-bottom:0px;">View Republishing Guidelines  <span id="butternutSquash"><i class="fas fa-caret-right" style="color:var(--brand_two);"></i></span></a>

		</div>
		<div class="col-12 col-md-6 d-flex justify-content-center flex-column align-items-center align-content-center align-content-md-end align-items-md-end mt-4 mt-md-0">
			<style> .republisherButton:hover {color: black;} </style>
		<button class="republisherButton" style="margin-top:0px;background-color:var(--brand_two);" onclick="copyToClipboard('#republication-tracker-tool-modal-content .articleContainer textarea')">Copy to clipboard</button>
	<div id="copyFBText" style="margin-top:10px;"></div>
		</div>
	</div>
	</div></div><div id="republication-tracker-tool-modal" style="display:none;" data-postid="3322" data-pluginsdir="https://alaskabeacon.com/wp-content/plugins">1</div><div class="repubWidgetContainer"><a class="imgLink" target="_blank" href="http://creativecommons.org/licenses/by-nd/4.0/"><img class="ccImg" alt="Creative Commons License" style="border-width:0" src="https://alaskabeacon.com/wp-content/plugins/states-newsroom/republisher/assets/img/ccwhite.png" /></a><div class="license"><button name="Republish" id="cc-btn" class="republication-tracker-tool-button">Republish</button></div></div></div></section>
</aside>                                        </div>
                                        <div class="col-xxl-7 col-xl-7 col-lg-7 col-md-7 col-sm-12 col-12">
                                            <p class="singleRepublisherText">Our stories may be republished online or in print under Creative Commons license CC BY-NC-ND 4.0. We ask that you edit only for style or to shorten, provide proper attribution and link to our web site. Please see our republishing guidelines for use of photos and graphics.</p>
                                        </div>
                                    </div>
                                </div>
                                <div class="col-xxl-1 col-xl-1 col-lg-1 col-md-0 col-sm-0 col-0"></div>
                            </div>
                                                    </div>
                        <div class="col-xxl-1 col-xl-1 col-lg-1 col-md-1 col-sm-0 col-0"></div>
                    </div>
                    <div class="row singleBottomRow">
                        <div class="col-xxl-1 col-xl-1 col-lg-0 col-md-0 col-sm-0 col-0"></div>

                        <div class="col-xxl-4 col-xl-4 col-lg-5 col-md-6 col-sm-12 col-12"> 
                            <div class="row authorBoxRow"><div class="col-3"><div class="authorBoxAvatar"><img src="https://alaskabeacon.com/wp-content/uploads/2022/05/0MtU5ASd_400x400-150x150.jpg" width="96" height="96" alt="Yereth Rosen" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></div></div><div class="col-9"><span class="authorBoxName"><a href="/author/yereth-rosen"><h6>Yereth Rosen</h6></a><a href="/cdn-cgi/l/email-protection#dfa6adb0acbab19fbeb3beacb4bebdbabebcb0b1f1bcb0b2"><i class="fas fa-envelope"></i></a><a href="https://twitter.com/YJRosen"><i class="fab fa-twitter"></i></a></span><div class="authorBoxDescription"><p>Yereth Rosen came to Alaska in 1987 to work for the Anchorage Times. She has been reporting on Alaska news ever since, covering stories ranging from oil spills to sled-dog races. She has reported for Reuters, for the Alaska Dispatch News, for Arctic Today and for other organizations. She covers environmental issues, energy, climate change, natural resources, economic and business news, health, science and Arctic concerns -- subjects with a lot of overlap. In her free time, she likes to ski and watch her son's hockey games.</p></div><a class="authorBoxMore" href="https://alaskabeacon.com/author/yereth-rosen">MORE FROM AUTHOR</a></div></div> 
                        </div>
                        <div class="col-xxl-6 col-xl-6 col-lg-7 col-md-6 col-sm-12 col-12 relatedCol"> 
                            <h4 class="relatedNewsTitle">Related News</h4>
                            <div class="crp_related  "><div class="row"><div class="col-xxl-4 col-xl-4 col-lg-4 col-md-6 col-sm-6 col-6"><a href="https://alaskabeacon.com/2022/10/04/interim-revenue-commissioner-deven-mitchell-is-new-ceo-of-alaska-permanent-fund-corp/"     class="crp_link post-2949"><figure><img  src="https://alaskabeacon.com/wp-content/uploads/2022/10/221003-Mitchell-web-300x203.jpg" class="crp_thumb crp_featured" alt="Interim Revenue Commissioner Deven Mitchell is new CEO of Alaska Permanent Fund Corp." title="Interim Revenue Commissioner Deven Mitchell is new CEO of Alaska Permanent Fund Corp." srcset="https://alaskabeacon.com/wp-content/uploads/2022/10/221003-Mitchell-web-300x203.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/10/221003-Mitchell-web-1024x694.jpg 1024w, https://alaskabeacon.com/wp-content/uploads/2022/10/221003-Mitchell-web-768x520.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/10/221003-Mitchell-web.jpg 1500w" sizes="(max-width: 300px) 100vw, 300px" srcset="https://alaskabeacon.com/wp-content/uploads/2022/10/221003-Mitchell-web-300x203.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/10/221003-Mitchell-web-1024x694.jpg 1024w, https://alaskabeacon.com/wp-content/uploads/2022/10/221003-Mitchell-web-768x520.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/10/221003-Mitchell-web.jpg 1500w" /></figure><span class="crp_title">Interim Revenue Commissioner Deven Mitchell is new CEO of&hellip;</span></a><span class="crp_author">  by <a href="https://alaskabeacon.com/author/james-brooks/">James Brooks</a></span> <span class="crp_date"> October 4, 2022</span> </div><div class="col-xxl-4 col-xl-4 col-lg-4 col-md-6 col-sm-6 col-6"><a href="https://alaskabeacon.com/2022/08/31/two-people-die-after-just-one-day-in-corrections-custody-this-month/"     class="crp_link post-2333"><figure><img  src="https://alaskabeacon.com/wp-content/uploads/2022/08/DSC07987-300x200.jpg" class="crp_thumb crp_featured" alt="Two people die after just one day in Alaska corrections custody this month" title="Two people die after just one day in Alaska corrections custody this month" srcset="https://alaskabeacon.com/wp-content/uploads/2022/08/DSC07987-300x200.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/08/DSC07987-1024x683.jpg 1024w, https://alaskabeacon.com/wp-content/uploads/2022/08/DSC07987-768x512.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/08/DSC07987-1536x1024.jpg 1536w, https://alaskabeacon.com/wp-content/uploads/2022/08/DSC07987-2048x1365.jpg 2048w" sizes="(max-width: 300px) 100vw, 300px" /></figure><span class="crp_title">Two people die after just one day in Alaska corrections&hellip;</span></a><span class="crp_author">  by <a href="https://alaskabeacon.com/author/lisa-phu/">Lisa Phu</a></span> <span class="crp_date"> August 31, 2022</span> </div><div class="col-xxl-4 col-xl-4 col-lg-4 col-md-6 col-sm-6 col-6"><a href="https://alaskabeacon.com/2022/09/26/to-reach-net-zero-the-world-still-needs-mining/"     class="crp_link post-2778"><figure><img  src="https://alaskabeacon.com/wp-content/uploads/2022/09/file-20220920-3427-nbxfx6-300x170.jpg" class="crp_thumb crp_featured" alt="To reach net zero the world still needs mining" title="To reach net zero the world still needs mining" srcset="https://alaskabeacon.com/wp-content/uploads/2022/09/file-20220920-3427-nbxfx6-300x170.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/09/file-20220920-3427-nbxfx6-768x435.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/09/file-20220920-3427-nbxfx6.jpg 1000w" sizes="(max-width: 300px) 100vw, 300px" srcset="https://alaskabeacon.com/wp-content/uploads/2022/09/file-20220920-3427-nbxfx6-300x170.jpg 300w, https://alaskabeacon.com/wp-content/uploads/2022/09/file-20220920-3427-nbxfx6-768x435.jpg 768w, https://alaskabeacon.com/wp-content/uploads/2022/09/file-20220920-3427-nbxfx6.jpg 1000w" /></figure><span class="crp_title">To reach net zero the world still needs mining</span></a><span class="crp_author">  by <a href="https://alaskabeacon.com/author/bridgetstorrie/">Bridget Storrie</a></span> <span class="crp_date"> September 26, 2022</span> </div></div><div class="crp_clear"></div></div>                        </div>
                        <div class="col-xxl-1 col-xl-1 col-lg-0 col-md-0 col-sm-0 col-0"></div>
                    </div>
                </div>    
            </div>
        </main><!-- .site-main -->
    </div><!-- .content-area -->

</div>
<footer>
    <div class="footerFullWidthTaglineRow">
        <div class="container">
            <div class="row">
                <div class="col-12 text-center">
                    <h2 class="footerTagline">INDEPENDENT AND ILLUMINATING JOURNALISM</h2>
                </div>
            </div>
        </div>
    </div>
    <div class="footerFullWidthContentRow">
        <div class="container">
            <div class="row democracyToolkitRow">
                <div class="col-12 democracyToolkitCol px-0">
                    <div class="democracyToolkitFlexContainer">
                        <h6>Democracy Toolkit  //  </h6>
                        <a target="_blank" href="https://voterregistration.alaska.gov/">Register to vote</a>
                        <span> | </span>
                        <a target="_blank" href="https://myvoterinformation.alaska.gov/">Find your polling place and registration status</a>
                        <span> | </span>
                        <a target="_blank" href="https://www.elections.alaska.gov/Core/AKVoteEarly.php">How to vote early or by mail</a>
                        <span> | </span>
                        <a target="_blank" href="https://aws.state.ak.us/OnlinePublicNotices/">View public notices</a>
                    </div>
                    <div class="democracyToolkitMobileContainer mobileOnly">
                        <ul id="accordion" class="accordion mobileFooterAccordian" style="list-style-type:none !important;">
                            <li>
                                <div class="link mobileDemocracyHeader"><p>DEMOCRACY TOOLKIT<i style="float:right;margin-top:8px;" id="accordianSwitch" class="fa fa-chevron-down"></i></p></div>
                                <ul class="submenu mobileDemocracySubmenu" style="display:none;">
                                    <li><a target="_blank" href="https://voterregistration.alaska.gov/">Register to vote</a></li>
                                    <li><a target="_blank" href="https://myvoterinformation.alaska.gov/">Find your polling place and registration status</a></li>
                                    <li><a target="_blank" href="https://www.elections.alaska.gov/Core/AKVoteEarly.php">How to vote early or by mail</a></li>
                                    <li><a target="_blank" href="https://aws.state.ak.us/OnlinePublicNotices/">View public notices</a></li>
                                </ul>
                            </li>
                        </ul>
                    </div>
                </div>
            </div>
            <div class="row">
                <div class="col-xxl-2 col-xl-2 col-lg-2 col-md-2 col-sm-4 col-4 text-center">
                    <img src="/wp-content/themes/genesis-child/icons/footerLogo.png" class="footerLogo" />
                    <p class="footerCopyright">&copy; Alaska Beacon, 2022</p>
                </div>
                <div class="col-xxl-4 col-xl-4 col-lg-4 col-md-4 col-sm-8 col-8 text-left footerAboutCol">
                    <span class="footerAboutColHead"><h4>ABOUT US</h4><a href="/cdn-cgi/l/email-protection#ee87808881ae8f828f9d858f8c8b8f8d8180c08d8183"><i class="fas fa-envelope"></i></a></span>
                    <p> The Alaska Beacon is an independent, nonpartisan news organization focused on connecting Alaskans to their state government. Our journalists fairly and fearlessly report on the people and interests that determine state policy.</p>
                    <p class="mobileOnly"><span class="footerTermsPrivacy"><a href="/deij-policy" style="color:white;line-height:15px;">DEIJ Policy</a> | <a href="/ethics-policy" style="color:white;line-height:15px;">Ethics Policy</a> | <a href="/privacy-policy" style="color:white;line-height:15px;">Privacy Policy</a></span></p>
                    <div class="footerSocialShares">
                        <span>
                            <a target="_blank" href="https://twitter.com/AlaskaBeacon">
                                <i class="fab fa-twitter"></i>
                            </a>
                            <a target="_blank" href="https://www.facebook.com/AlaskaBeacon">
                                <i class="fab fa-facebook-f"></i>
                            </a>
                                                        <a target="_blank" href="https://apple.news/Txky9Is5mQWyfdbZ3wOtbDg">
                                <i class="fab fa-apple"></i>
                            </a>
                        </span>
                    </div>
                </div>
                <div class="col-xxl-3 col-xl-3 col-lg-3 col-md-1 col-sm-0 col-0"></div>
                <div class="col-xxl-3 col-xl-3 col-lg-3 col-md-5 col-sm-12 col-12 footerRepublisher">
                    <img src="/wp-content/themes/genesis-child/icons/ccwhite.png" class="footerCCLogo" />
                    <p>Our stories may be republished online or in print under Creative Commons licence CC BY-NC-ND 4.0. We ask that you edit only for style or to shorten, provide proper attribution and link to our web site.</p>
                    <span class="footerTermsPrivacy mobileOff"><a href="/deij-policy">DEIJ Policy</a> | <a href="/ethics-policy">Ethics Policy</a> | <a href="/privacy-policy">Privacy Policy</a></span>
                </div>
                <div class="col-xxl-0 col-xl-0 col-lg-0 col-md-0 col-sm-12 col-12 mobileOnly tabletToo">
                    <div class="footerMobileSocialFlexContainer">
                        <a target="_blank" href="/cdn-cgi/l/email-protection#f990979f96b99895988a92989b9c989a9697d79a9694">
                            <i class="fas fa-envelope"></i>
                        </a>
                        <a target="_blank" href="https://twitter.com/AlaskaBeacon">
                            <i class="fab fa-twitter"></i>
                        </a>
                        <a target="_blank" href="https://www.facebook.com/AlaskaBeacon">
                            <i class="fab fa-facebook-f"></i>
                        </a>
                                                <a target="_blank" href="https://apple.news/Txky9Is5mQWyfdbZ3wOtbDg">
                            <i class="fab fa-apple"></i>
                        </a>
        
                    </div>
                    <div class="mobileOnly tabletToo footerMobileCopyrightContainer">
                        <span class="footerCopyrightMobile">&copy; Alaska Beacon, 2022</span>
                    </div>
                </div>
            </div>

        </div>
    </div>
</footer>
</div><link rel='stylesheet' id='republication-tracker-tool-css-css'  href='https://alaskabeacon.com/wp-content/plugins/states-newsroom/republisher/assets/widget.css?ver=1.0.1' type='text/css' media='all' />
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='https://alaskabeacon.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://alaskabeacon.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.13.1' id='jquery-ui-datepicker-js'></script>
<script type='text/javascript' id='jquery-ui-datepicker-js-after'>
jQuery(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://alaskabeacon.com/wp-includes/js/comment-reply.min.js?ver=5.9.5' id='comment-reply-js'></script>
<script type='text/javascript' src='https://alaskabeacon.com/wp-content/plugins/states-newsroom/republisher/assets/widget.js?ver=1.0.1' id='republication-tracker-tool-js-js'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"NRJS-5e80c6ce4b880b7c309","applicationID":"986008064","transactionName":"Y11VMhNRWRIFVkQLDVoXdgUVWVgPS0ZZDAVYXQ==","queueTime":0,"applicationTime":206,"atts":"TxpWRFtLShw=","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html>
